What’s Vulnerable › Vulnerabilities
CVE-2021-47987: Parse Server - Arbitrary Code Execution via Malicious Version Tags
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-25 · updated 2026-06-26
- Weakness: CWE-494
Description
Parse Server before 4.10.0 was affected by a supply chain incident in which incorrect version tags were pushed to the official repository pointing to an unreviewed personal fork of a contributor with write access. No releases were published with these tags; a project was exposed only if it defined a git-based dependency referencing one of the affected tags (for example, parse-server#4.9.3). The code behind the tags was not reviewed or approved, and although no malicious code was identified, the introduction of security vulnerabilities could not be ruled out.
Affected products
- parse-community parse-server: before 4.10.0 — fixed in 4.10.0
How to fix
Upgrade to a fixed version: parse-community parse-server 4.10.0. Check the vendor advisory for mitigations.
References
- https://github.com/parse-community/parse-server/security/advisories/GHSA-593v-wcqx-hq2w
- https://www.vulncheck.com/advisories/parse-server-arbitrary-code-execution-via-malicious-version-tags
Get alerted when CVE-2021-47987 or the next vulnerability affects your stack