What’s Vulnerable › Vulnerabilities
CVE-2021-48007: PocketMine-MP before 3.18.1 Denial of Service via MovePlayerPacket
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-06 · updated 2026-10-08
- Weakness: CWE-20
Description
PocketMine-MP versions before 3.18.1 fail to validate NaN or INF values in MovePlayerPacket position and rotation fields. Malicious clients can send crafted movement packets with invalid floating-point values to crash servers through unhandled mathematical operations or prevent clients from rendering other players.
Affected products
- pmmp PocketMine-MP: before 3.18.1 — fixed in 3.18.1
How to fix
Upgrade to a fixed version: pmmp PocketMine-MP 3.18.1. Check the vendor advisory for mitigations.
References
- https://github.com/pmmp/PocketMine-MP/commit/fb20bb38327b4c08ee3976640cd0dd547388a638
- https://github.com/pmmp/PocketMine-MP/security/advisories/GHSA-fm35-jgg3-3grx
- https://www.vulncheck.com/advisories/pocketmine-mp-before-3.18.1-denial-of-service-via-moveplayerpacket
Get alerted when CVE-2021-48007 or the next vulnerability affects your stack