What’s Vulnerable › Vulnerabilities
CVE-2021-48018: Vyper 0.2.13 before 0.2.15 Storage Corruption via @nonreentrant Decorator
- Severity: high (CVSS 7.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-21 · updated 2026-10-23
- Weakness: CWE-787
Description
Vyper from 0.2.13 before 0.2.15 allocates storage slots for @nonreentrant reentrancy locks at the same locations as contract storage variables. When a function using @nonreentrant is called, setting the lock overwrites the overlapping storage variable, corrupting contract state and breaking the contract's intended logic.
Affected products
- vyperlang vyper: from 0.2.13 before 0.2.15 — fixed in 0.2.15
How to fix
Upgrade to a fixed version: vyperlang vyper 0.2.15. Check the vendor advisory for mitigations.
References
- https://github.com/vyperlang/vyper/security/advisories/GHSA-7f92-rr6w-cq64
- https://www.vulncheck.com/advisories/vyper-0.2.13-before-0.2.15-storage-corruption-via-nonreentrant-decorator
Get alerted when CVE-2021-48018 or the next vulnerability affects your stack