What’s Vulnerable › Vulnerabilities
CVE-2021-48020: Vyper before 0.3.0 Memory Corruption via Internal Function Calls in Arrays
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-21 · updated 2026-10-28
- Weakness: CWE-787
Description
Vyper from 0.1.0b4 before 0.3.0 contains a memory corruption vulnerability caused by an incorrect stack tip pointer when internal function calls are performed inside arrays. Contracts placing internal calls in nested array elements, external call arguments, struct literals, or raw_log topics can have memory corrupted, producing incorrect contract behavior.
Affected products
- vyperlang vyper: from 0.1.0b4 before 0.3.0 — fixed in 0.3.0
How to fix
Upgrade to a fixed version: vyperlang vyper 0.3.0. Check the vendor advisory for mitigations.
References
- https://github.com/vyperlang/vyper/security/advisories/GHSA-22wc-c9wj-6q2v
- https://www.vulncheck.com/advisories/vyper-before-0.3.0-memory-corruption-via-internal-function-calls-in-arrays
Get alerted when CVE-2021-48020 or the next vulnerability affects your stack