What’s Vulnerable › Vulnerabilities
CVE-2022-0019: GlobalProtect App: Insufficiently Protected Credentials Vulnerability on Linux
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-02-10 · updated 2026-06-17
- Weakness: CWE-522
Description
An insufficiently protected credentials vulnerability exists in the Palo Alto Networks GlobalProtect app on Linux that exposes the hashed credentials of GlobalProtect users that saved their password during previous GlobalProtect app sessions to other local users on the system. The exposed credentials enable a local attacker to authenticate to the GlobalProtect portal or gateway as the target user without knowing of the target user’s plaintext password. This issue impacts: GlobalProtect app 5.1 versions earlier than GlobalProtect app 5.1.10 on Linux. GlobalProtect app 5.2 versions earlier than and including GlobalProtect app 5.2.7 on Linux. GlobalProtect app 5.3 versions earlier than GlobalProtect app 5.3.2 on Linux. This issue does not affect the GlobalProtect app on other platforms.
Affected products
- Palo Alto Networks GlobalProtect App: from 5.1 before 5.1.10; from 5.2 through 5.2.7; from 5.3 before 5.3.2 — fixed in 5.1.10, 5.3.2
- Palo Alto Networks GlobalProtect App: from 5.3 before 5.3.2; from 5.2 through 5.2.7; from 5.1 before 5.1.10 — fixed in 5.3.2, 5.1.10
How to fix
Upgrade to a fixed version: Palo Alto Networks GlobalProtect App 5.1.10, 5.3.2; Palo Alto Networks GlobalProtect App 5.3.2, 5.1.10. Check the vendor advisory for mitigations.
References
- https://security.paloaltonetworks.com/CVE-2022-0019
- https://security.paloaltonetworks.com/CVE-2022-0019
Get alerted when CVE-2022-0019 or the next vulnerability affects your stack