What’s Vulnerable › Vulnerabilities
CVE-2022-0022: PAN-OS: Use of a Weak Cryptographic Algorithm for Stored Password Hashes
- Severity: medium (CVSS 4.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-03-09 · updated 2026-06-17
- Weakness: CWE-916
Description
Usage of a weak cryptographic algorithm in Palo Alto Networks PAN-OS software where the password hashes of administrator and local user accounts are not created with a sufficient level of computational effort, which allows for password cracking attacks on accounts in normal (non-FIPS-CC) operational mode. An attacker must have access to the account password hashes to take advantage of this weakness and can acquire those hashes if they are able to gain access to the PAN-OS software configuration. Fixed versions of PAN-OS software use a secure cryptographic algorithm for account password hashes. This issue does not impact Prisma Access firewalls. This issue impacts: PAN-OS 8.1 versions earlier than PAN-OS 8.1.21; All versions of PAN-OS 9.0; PAN-OS 9.1 versions earlier than PAN-OS 9.1.11; PAN-OS 10.0 versions earlier than PAN-OS 10.0.7.
Affected products
- Palo Alto Networks PAN-OS: from 8.1.0 before 8.1.21; from 9.0.0 through 9.0.15; from 9.1.0 before 9.1.11; from 10.0.0 before 10.0.7 — fixed in 8.1.21, 9.1.11, 10.0.7
- Palo Alto Networks PAN-OS: from 9.1 before 9.1.11; from 8.1 before 8.1.21; from 10.0 before 10.0.7; 9.0.* — fixed in 9.1.11, 8.1.21, 10.0.7
How to fix
Upgrade to a fixed version: Palo Alto Networks PAN-OS 8.1.21, 9.1.11, 10.0.7; Palo Alto Networks PAN-OS 9.1.11, 8.1.21, 10.0.7. Check the vendor advisory for mitigations.
References
- https://security.paloaltonetworks.com/CVE-2022-0022
- https://security.paloaltonetworks.com/CVE-2022-0022
Get alerted when CVE-2022-0022 or the next vulnerability affects your stack