What’s Vulnerable › Vulnerabilities
CVE-2022-0024: PAN-OS: Improper Neutralization Vulnerability Leads to Unintended Program Execution During Configuration Commit
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-05-11 · updated 2026-06-17
- Weakness: CWE-138
Description
A vulnerability exists in Palo Alto Networks PAN-OS software that enables an authenticated network-based PAN-OS administrator to upload a specifically created configuration that disrupts system processes and potentially execute arbitrary code with root privileges when the configuration is committed on both hardware and virtual firewalls. This issue does not impact Panorama appliances or Prisma Access customers. This issue impacts: PAN-OS 8.1 versions earlier than PAN-OS 8.1.23; PAN-OS 9.0 versions earlier than PAN-OS 9.0.16; PAN-OS 9.1 versions earlier than PAN-OS 9.1.13; PAN-OS 10.0 versions earlier than PAN-OS 10.0.10; PAN-OS 10.1 versions earlier than PAN-OS 10.1.5.
Affected products
- Palo Alto Networks PAN-OS: from 8.1.0 before 8.1.23; from 9.0.0 before 9.0.16; from 9.1.0 before 9.1.13; from 10.0.0 before 10.0.10; from 10.1.0 before 10.1.5 — fixed in 8.1.23, 9.0.16, 9.1.13, 10.0.10, 10.1.5
- Palo Alto Networks PAN-OS: from 9.1 before 9.1.13; from 10.1 before 10.1.5; from 9.0 before 9.0.16; from 8.1 before 8.1.23; from 10.0 before 10.0.10 — fixed in 9.1.13, 10.1.5, 9.0.16, 8.1.23, 10.0.10
How to fix
Upgrade to a fixed version: Palo Alto Networks PAN-OS 8.1.23, 9.0.16, 9.1.13, 10.0.10; Palo Alto Networks PAN-OS 9.1.13, 10.1.5, 9.0.16, 8.1.23. Check the vendor advisory for mitigations.
References
- https://security.paloaltonetworks.com/CVE-2022-0024
- https://security.paloaltonetworks.com/CVE-2022-0024
Get alerted when CVE-2022-0024 or the next vulnerability affects your stack