What’s Vulnerable › Vulnerabilities
CVE-2022-0028: Palo Alto Networks PAN-OS Reflected Amplification Denial-of-Service Vulnerability
- Severity: high (CVSS 8.6 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2022-08-22
- EPSS: 2.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-10 · updated 2026-06-17
- Weakness: CWE-406
Description
A PAN-OS URL filtering policy misconfiguration could allow a network-based attacker to conduct reflected and amplified TCP denial-of-service (RDoS) attacks. The DoS attack would appear to originate from a Palo Alto Networks PA-Series (hardware), VM-Series (virtual) and CN-Series (container) firewall against an attacker-specified target. To be misused by an external attacker, the firewall configuration must have a URL filtering profile with one or more blocked categories assigned to a source zone that has an external facing interface. This configuration is not typical for URL filtering and, if set, is likely unintended by the administrator. If exploited, this issue would not impact the confidentiality, integrity, or availability of our products. However, the resulting denial-of-service (DoS) attack may help obfuscate the identity of the attacker and implicate the firewall as the source of the attack. We have taken prompt action to address this issue in our PAN-OS software. All software updates for this issue are expected to be released no later than the week of August 15, 2022. This issue does not impact Panorama M-Series or Panorama virtual appliances. This issue has been resolved for all Cloud NGFW and Prisma Access customers and no additional action is required from them.
Affected products
- Palo Alto Networks PAN-OS: from 8.1.0 before 8.1.23; from 9.0.0 before 9.0.16; from 9.1.0 before 9.1.14; from 10.0.0 before 10.0.11; from 10.1.0 before 10.1.6; from 10.2.0 before 10.2.2 — fixed in 10.0.11, 10.1.6, 10.2.2, 8.1.23, 9.0.16, 9.1.14
How to fix
Upgrade to a fixed version: Palo Alto Networks PAN-OS 10.0.11, 10.1.6, 10.2.2, 8.1.23. Check the vendor advisory for mitigations.
References
- https://security.paloaltonetworks.com/CVE-2022-0028
- https://security.paloaltonetworks.com/CVE-2022-0028
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2022-0028
Get alerted when CVE-2022-0028 or the next vulnerability affects your stack