What’s Vulnerable › Vulnerabilities
CVE-2022-0072: Directory Traversal in OpenLiteSpeed Web Server
- Severity: medium (CVSS 5.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-10-27 · updated 2026-06-17
- Weakness: CWE-22
Description
Directory Traversal vulnerability in LiteSpeed Technologies OpenLiteSpeed Web Server and LiteSpeed Web Server dashboards allows Path Traversal. This affects versions from 1.5.11 through 1.5.12, from 1.6.5 through 1.6.20.1, from 1.7.0 before 1.7.16.1
Affected products
- LiteSpeed Technologies OpenLiteSpeed: from 1.6.5 through 1.6.20.1; from 1.7.0 before 1.7.16.1; 1.5.11, 1.5.12 — fixed in 1.7.16.1
How to fix
Upgrade to a fixed version: LiteSpeed Technologies OpenLiteSpeed 1.7.16.1. Check the vendor advisory for mitigations.
References
- https://github.com/litespeedtech/openlitespeed/blob/v1.7.16.1/src/main/httpserver.cpp#L2060-L2061
- https://github.com/litespeedtech/openlitespeed/blob/v1.7.16/src/main/httpserver.cpp#L2060-L2061
- https://github.com/litespeedtech/openlitespeed/blob/v1.7.16.1/src/main/httpserver.cpp#L2060-L2061
- https://github.com/litespeedtech/openlitespeed/blob/v1.7.16/src/main/httpserver.cpp#L2060-L2061
Get alerted when CVE-2022-0072 or the next vulnerability affects your stack