What’s Vulnerable › Vulnerabilities
CVE-2022-0074: Privilege Escalation in OpenLiteSpeed Web Server
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-10-27 · updated 2026-06-17
- Weakness: CWE-426
Description
Untrusted Search Path vulnerability in LiteSpeed Technologies OpenLiteSpeed Web Server and LiteSpeed Web Server Container allows Privilege Escalation. This affects versions from 1.6.15 before 1.7.16.1.
Affected products
- LiteSpeed Technologies OpenLiteSpeed: from 1.6.15 before 1.7.16.1 — fixed in 1.7.16.1
How to fix
Upgrade to a fixed version: LiteSpeed Technologies OpenLiteSpeed 1.7.16.1. Check the vendor advisory for mitigations.
References
- https://github.com/litespeedtech/ols-dockerfiles/blob/master/template/Dockerfile#L29
- https://github.com/litespeedtech/ols-dockerfiles/blob/master/template/Dockerfile#L29
Get alerted when CVE-2022-0074 or the next vulnerability affects your stack