What’s Vulnerable › Vulnerabilities
CVE-2022-0086: Server-Side Request Forgery (SSRF) in transloadit/uppy
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-04 · updated 2026-06-17
- Weakness: CWE-918
Description
uppy is vulnerable to Server-Side Request Forgery (SSRF)
Affected products
- transloadit/uppy: before 2.3.3 — fixed in 2.3.3
How to fix
Upgrade to a fixed version: transloadit/uppy 2.3.3. Check the vendor advisory for mitigations.
References
- https://github.com/transloadit/uppy/commit/fc137e30a2a3102eb191141f280d5de20dacdf8f
- https://huntr.dev/bounties/c1c03ef6-3f18-4976-a9ad-08c251279122
- https://github.com/transloadit/uppy/commit/fc137e30a2a3102eb191141f280d5de20dacdf8f
- https://huntr.dev/bounties/c1c03ef6-3f18-4976-a9ad-08c251279122
Get alerted when CVE-2022-0086 or the next vulnerability affects your stack