What’s Vulnerable › Vulnerabilities
CVE-2022-0088: Cross-Site Request Forgery (CSRF) in yourls/yourls
- Severity: high (CVSS 7.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-04-03 · updated 2026-06-17
- Weakness: CWE-352
Description
Cross-Site Request Forgery (CSRF) in GitHub repository yourls/yourls prior to 1.8.3.
Affected products
- yourls/yourls: before 1.8.3 — fixed in 1.8.3
How to fix
Upgrade to a fixed version: yourls/yourls 1.8.3. Check the vendor advisory for mitigations.
References
- https://github.com/yourls/yourls/commit/1de256d8694b0ec7d4df2ac1d5976d4055e09d59
- https://huntr.dev/bounties/d01f0726-1a0f-4575-ae17-4b5319b11c29
- https://github.com/MarkLee131/awesome-web-pocs/blob/main/CVE-2022-0088.md
- https://github.com/yourls/yourls/commit/1de256d8694b0ec7d4df2ac1d5976d4055e09d59
- https://huntr.dev/bounties/d01f0726-1a0f-4575-ae17-4b5319b11c29
Get alerted when CVE-2022-0088 or the next vulnerability affects your stack