What’s Vulnerable › Vulnerabilities

CVE-2022-0123

Description

An issue has been discovered affecting GitLab versions prior to 14.4.5, between 14.5.0 and 14.5.3, and between 14.6.0 and 14.6.1. GitLab does not validate SSL certificates for some of external CI services which makes it possible to perform MitM attacks on connections to these external services.

Affected products

How to fix

Upgrade to a fixed version: GitLab 14.4.5, 14.5.3, 14.6.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-0123 or the next vulnerability affects your stack