What’s Vulnerable › Vulnerabilities
CVE-2022-0128: Out-of-bounds Read in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-06 · updated 2026-06-17
- Weakness: CWE-125
Description
vim is vulnerable to Out-of-bounds Read
Affected products
- macOS: 10.15.7-security_update_2020-001, 10.15.7-security_update_2021-001, 10.15.7-security_update_2021-002, 10.15.7-security_update_2021-003, 10.15.7-security_update_2021-004, 10.15.7-security_update_2021-005 (+6)
- Apple macOS: before 10.15.7; from 11.0 before 11.6.6; 10.15.7, 10.15.7-security_update_2022-004 — fixed in 10.15.7, 11.6.6
- vim/vim: before 8.2.4009 — fixed in 8.2.4009
How to fix
Upgrade to a fixed version: Apple macOS 10.15.7, 11.6.6; vim/vim 8.2.4009. Check the vendor advisory for mitigations.
References
- http://seclists.org/fulldisclosure/2022/Jul/14
- http://seclists.org/fulldisclosure/2022/Mar/29
- http://seclists.org/fulldisclosure/2022/May/35
- http://www.openwall.com/lists/oss-security/2022/01/15/1
- https://github.com/vim/vim/commit/d3a117814d6acbf0dca3eff1a7626843b9b3734a
- https://huntr.dev/bounties/63f51299-008a-4112-b85b-1e904aadd4ba
- https://security.gentoo.org/glsa/202208-32
- https://support.apple.com/kb/HT213183
- https://support.apple.com/kb/HT213256
- https://support.apple.com/kb/HT213343
- http://seclists.org/fulldisclosure/2022/Jul/14
- http://seclists.org/fulldisclosure/2022/Mar/29
Get alerted when CVE-2022-0128 or the next vulnerability affects your stack