What’s Vulnerable › Vulnerabilities
CVE-2022-0135
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-25 · updated 2026-06-17
- Weakness: CWE-787
Description
An out-of-bounds write issue was found in the VirGL virtual OpenGL renderer (virglrenderer). This flaw allows a malicious guest to create a specially crafted virgil resource and then issue a VIRTGPU_EXECBUFFER ioctl, leading to a denial of service or possible code execution.
Affected products
- Debian Linux: 10.0
- Red Hat Enterprise Linux: 8.0
- Virglrenderer Project Virglrenderer: from 0.8.1 before 0.10.0 — fixed in 0.10.0
How to fix
Upgrade to a fixed version: Virglrenderer Project Virglrenderer 0.10.0. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=2037790
- https://lists.debian.org/debian-lts-announce/2022/12/msg00017.html
- https://security.gentoo.org/glsa/202210-05
- https://bugzilla.redhat.com/show_bug.cgi?id=2037790
- https://lists.debian.org/debian-lts-announce/2022/12/msg00017.html
- https://security.gentoo.org/glsa/202210-05
Get alerted when CVE-2022-0135 or the next vulnerability affects your stack