What’s Vulnerable › Vulnerabilities
CVE-2022-0137
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-11-14 · updated 2026-06-17
- Weakness: CWE-119
Description
A heap buffer overflow in image_set_mask function of HTMLDOC before 1.9.15 allows an attacker to write outside the buffer boundaries.
Affected products
- htmldoc: before 1.9.15 — fixed in 1.9.15
How to fix
Upgrade to a fixed version: htmldoc 1.9.15. Check the vendor advisory for mitigations.
References
- https://github.com/michaelrsweet/htmldoc/commit/71fe87878c9cbc3db429f5e5c70f28e4b3d96e3b
- https://github.com/michaelrsweet/htmldoc/issues/461
- https://github.com/michaelrsweet/htmldoc/commit/71fe87878c9cbc3db429f5e5c70f28e4b3d96e3b
- https://github.com/michaelrsweet/htmldoc/issues/461
Get alerted when CVE-2022-0137 or the next vulnerability affects your stack