What’s Vulnerable › Vulnerabilities
CVE-2022-0141: Visual Form Builder < 3.0.8 - Entries Deletion/Restoration via CSRF
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-12 · updated 2026-06-17
- Weakness: CWE-352
Description
The Visual Form Builder WordPress plugin before 3.0.8 does not enforce nonce checks which could allow attackers to make a logged in admin or editor delete and restore arbitrary form entries via CSRF attacks
Affected products
- Visual Form Builder: before 3.0.6 — fixed in 3.0.6
How to fix
Upgrade to a fixed version: Visual Form Builder 3.0.6. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/2adc8390-bb19-4adf-9805-e9c462d14d22
- https://www.fortiguard.com/zeroday/FG-VD-21-081
- https://wpscan.com/vulnerability/2adc8390-bb19-4adf-9805-e9c462d14d22
- https://www.fortiguard.com/zeroday/FG-VD-21-081
Get alerted when CVE-2022-0141 or the next vulnerability affects your stack