What’s Vulnerable › Vulnerabilities
CVE-2022-0144: Improper Privilege Management in shelljs/shelljs
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-11 · updated 2026-10-08
- Weakness: CWE-269
Description
shelljs is vulnerable to Improper Privilege Management
Affected products
- shelljs/shelljs: before 0.8.5 — fixed in 0.8.5
- Npm Shelljs: before 0.8.5 — fixed in 0.8.5
How to fix
Upgrade to a fixed version: shelljs/shelljs 0.8.5; Npm Shelljs 0.8.5. Check the vendor advisory for mitigations.
References
- https://github.com/shelljs/shelljs/commit/d919d22dd6de385edaa9d90313075a77f74b338c
- https://huntr.dev/bounties/50996581-c08e-4eed-a90e-c0bac082679c
- https://github.com/shelljs/shelljs/commit/d919d22dd6de385edaa9d90313075a77f74b338c
- https://huntr.dev/bounties/50996581-c08e-4eed-a90e-c0bac082679c
Get alerted when CVE-2022-0144 or the next vulnerability affects your stack