What’s Vulnerable › Vulnerabilities
CVE-2022-0150: WP Accessibility Helper (WAH) < 0.6.0.7 - Reflected Cross-Site Scripting (XSS)
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-28 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP Accessibility Helper (WAH) WordPress plugin before 0.6.0.7 does not sanitise and escape the wahi parameter before outputting back its base64 decode value in the page, leading to a Reflected Cross-Site Scripting issue
Affected products
- WP Accessibility Helper (WAH): before 0.6.0.7 — fixed in 0.6.0.7
How to fix
Upgrade to a fixed version: WP Accessibility Helper (WAH) 0.6.0.7. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2661008
- https://wpscan.com/vulnerability/7142a538-7c3d-4dd0-bd2c-cbd2efaf53c5
- https://plugins.trac.wordpress.org/changeset/2661008
- https://wpscan.com/vulnerability/7142a538-7c3d-4dd0-bd2c-cbd2efaf53c5
Get alerted when CVE-2022-0150 or the next vulnerability affects your stack