What’s Vulnerable › Vulnerabilities
CVE-2022-0156: Use After Free in vim/vim
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-10 · updated 2026-06-17
- Weakness: CWE-416
Description
vim is vulnerable to Use After Free
Affected products
- Apple macOS: before 12.3; from 11.0 before 11.6.8 — fixed in 11.6.8, 12.3
- Fedoraproject Fedora: 34, 35
- vim/vim: before 8.2.4040 — fixed in 8.2.4040
How to fix
Upgrade to a fixed version: Apple macOS 11.6.8, 12.3; vim/vim 8.2.4040. Check the vendor advisory for mitigations.
References
- http://seclists.org/fulldisclosure/2022/Jul/13
- http://seclists.org/fulldisclosure/2022/Mar/29
- http://www.openwall.com/lists/oss-security/2022/01/15/1
- https://github.com/vim/vim/commit/9f1a39a5d1cd7989ada2d1cb32f97d84360e050f
- https://huntr.dev/bounties/47dded34-3767-4725-8c7c-9dcb68c70b36
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/3FH2J57GDA2WMBS6J56F6QQRA6BXQQFZ/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/HD5S2FC2HF22A7XQXK2XXIR46EARVWIM/
- https://security.gentoo.org/glsa/202208-32
- https://support.apple.com/kb/HT213183
- https://support.apple.com/kb/HT213344
- http://seclists.org/fulldisclosure/2022/Jul/13
- http://seclists.org/fulldisclosure/2022/Mar/29
Get alerted when CVE-2022-0156 or the next vulnerability affects your stack