What’s Vulnerable › Vulnerabilities
CVE-2022-0158: Heap-based Buffer Overflow in vim/vim
- Severity: low (CVSS 3.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-10 · updated 2026-06-17
- Weakness: CWE-122
Description
vim is vulnerable to Heap-based Buffer Overflow
Affected products
- Apple macOS: before 12.3; from 11.0 before 11.6.8 — fixed in 11.6.8, 12.3
- Fedoraproject Fedora: 34, 35
- vim/vim: before 8.2.4049 — fixed in 8.2.4049
How to fix
Upgrade to a fixed version: Apple macOS 11.6.8, 12.3; vim/vim 8.2.4049. Check the vendor advisory for mitigations.
References
- http://seclists.org/fulldisclosure/2022/Jul/13
- http://seclists.org/fulldisclosure/2022/Mar/29
- http://www.openwall.com/lists/oss-security/2022/01/15/1
- https://github.com/vim/vim/commit/5f25c3855071bd7e26255c68bf458b1b5cf92f39
- https://huntr.dev/bounties/ac5d7005-07c6-4a0a-b251-ba9cdbf6738b
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/3FH2J57GDA2WMBS6J56F6QQRA6BXQQFZ/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/HD5S2FC2HF22A7XQXK2XXIR46EARVWIM/
- https://security.gentoo.org/glsa/202208-32
- https://support.apple.com/kb/HT213183
- https://support.apple.com/kb/HT213344
- http://seclists.org/fulldisclosure/2022/Jul/13
- http://seclists.org/fulldisclosure/2022/Mar/29
Get alerted when CVE-2022-0158 or the next vulnerability affects your stack