What’s Vulnerable › Vulnerabilities
CVE-2022-0159: Cross-site Scripting (XSS) - Stored in orchardcms/orchardcore
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-12 · updated 2026-06-17
- Weakness: CWE-79
Description
orchardcore is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
Affected products
- orchardcms/orchardcore: before 1.2.1 — fixed in 1.2.1
How to fix
Upgrade to a fixed version: orchardcms/orchardcore 1.2.1. Check the vendor advisory for mitigations.
References
- https://github.com/orchardcms/orchardcore/commit/4da927d39a49138527c30db09c962ff706f95202
- https://huntr.dev/bounties/00937280-e2ab-49fe-8d43-8235b3c3db4b
- https://github.com/orchardcms/orchardcore/commit/4da927d39a49138527c30db09c962ff706f95202
- https://huntr.dev/bounties/00937280-e2ab-49fe-8d43-8235b3c3db4b
Get alerted when CVE-2022-0159 or the next vulnerability affects your stack