What’s Vulnerable › Vulnerabilities
CVE-2022-0171
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-26 · updated 2026-10-14
- Weakness: CWE-459
Description
A flaw was found in the Linux kernel. The existing KVM SEV API has a vulnerability that allows a non-root (host) user-level application to crash the host kernel by creating a confidential guest VM instance in AMD CPU that supports Secure Encrypted Virtualization (SEV).
Affected products
- Debian Linux: 10.0, 11.0
- Linux kernel: before 5.18; 5.18, 5.18-rc1, 5.18-rc2, 5.18-rc3 — fixed in 5.18
- Red Hat Enterprise Linux: 8.0, 9.0
How to fix
Upgrade to a fixed version: Linux kernel 5.18. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/security/cve/CVE-2022-0171
- https://bugzilla.redhat.com/show_bug.cgi?id=2038940
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=683412ccf61294d727ead4a73d97397396e69a6b
- https://lists.debian.org/debian-lts-announce/2022/11/msg00001.html
- https://www.debian.org/security/2022/dsa-5257
- https://access.redhat.com/security/cve/CVE-2022-0171
- https://bugzilla.redhat.com/show_bug.cgi?id=2038940
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=683412ccf61294d727ead4a73d97397396e69a6b
- https://lists.debian.org/debian-lts-announce/2022/11/msg00001.html
- https://www.debian.org/security/2022/dsa-5257
- https://cert-portal.siemens.com/productcert/html/ssa-794697.html
Get alerted when CVE-2022-0171 or the next vulnerability affects your stack