What’s Vulnerable › Vulnerabilities
CVE-2022-0172
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-01-18 · updated 2026-06-17
Description
An issue has been discovered in GitLab CE/EE affecting all versions starting with 12.3. Under certain conditions it was possible to bypass the IP restriction for public projects through GraphQL allowing unauthorised users to read titles of issues, merge requests and milestones.
Affected products
- GitLab: from 13.2 before 14.4.5; from 14.5.0 before 14.5.3; from 14.6.0 before 14.6.2 — fixed in 14.4.5, 14.5.3, 14.6.2
How to fix
Upgrade to a fixed version: GitLab 14.4.5, 14.5.3, 14.6.2. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/cves/-/blob/master/2022/CVE-2022-0172.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/348411
- https://gitlab.com/gitlab-org/cves/-/blob/master/2022/CVE-2022-0172.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/348411
Get alerted when CVE-2022-0172 or the next vulnerability affects your stack