What’s Vulnerable › Vulnerabilities
CVE-2022-0185: Linux Kernel Heap-Based Buffer Overflow Vulnerability
- Severity: high (CVSS 8.4 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2024-08-21
- EPSS: 25.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-11 · updated 2026-06-17
- Weakness: CWE-190
Description
A heap-based buffer overflow flaw was found in the way the legacy_parse_param function in the Filesystem Context functionality of the Linux kernel verified the supplied parameters length. An unprivileged (in case of unprivileged user namespaces enabled, otherwise needs namespaced CAP_SYS_ADMIN privilege) local user able to open a filesystem that does not support the Filesystem Context API (and thus fallbacks to legacy handling) could use this flaw to escalate their privileges on the system.
Affected products
- Linux kernel: from 5.1 before 5.4.173; from 5.5 before 5.10.93; from 5.11 before 5.15.16; from 5.16 before 5.16.2 — fixed in 5.10.93, 5.15.16, 5.16.2, 5.4.173
- NetApp H300E Firmware: all versions
- NetApp H300S Firmware: all versions
- NetApp H410C Firmware: all versions
- NetApp H410S Firmware: all versions
- NetApp H500E Firmware: all versions
- NetApp H500S Firmware: all versions
- NetApp H700E Firmware: all versions
- NetApp H700S Firmware: all versions
How to fix
Upgrade to a fixed version: Linux kernel 5.10.93, 5.15.16, 5.16.2, 5.4.173. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=722d94847de2
- https://github.com/Crusaders-of-Rust/CVE-2022-0185
- https://security.netapp.com/advisory/ntap-20220225-0003/
- https://www.openwall.com/lists/oss-security/2022/01/18/7
- https://www.willsroot.io/2022/01/cve-2022-0185.html
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=722d94847de2
- https://github.com/Crusaders-of-Rust/CVE-2022-0185
- https://security.netapp.com/advisory/ntap-20220225-0003/
- https://www.openwall.com/lists/oss-security/2022/01/18/7
- https://www.willsroot.io/2022/01/cve-2022-0185.html
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2022-0185
Get alerted when CVE-2022-0185 or the next vulnerability affects your stack