What’s Vulnerable › Vulnerabilities
CVE-2022-0189: WP RSS Aggregator < 4.20 - Reflected Cross-Site Scripting (XSS)
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-28 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP RSS Aggregator WordPress plugin before 4.20 does not sanitise and escape the id parameter in the wprss_fetch_items_row_action AJAX action before outputting it back in the response, leading to a Reflected Cross-Site Scripting
Affected products
- WP RSS Aggregator – News Feeds, Autoblogging, Youtube Video Feeds and More: before 4.20 — fixed in 4.20
How to fix
Upgrade to a fixed version: WP RSS Aggregator – News Feeds, Autoblogging, Youtube Video Feeds and More 4.20. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2659298
- https://wpscan.com/vulnerability/52a71bf1-b8bc-479e-b741-eb8fb9685014
- https://plugins.trac.wordpress.org/changeset/2659298
- https://wpscan.com/vulnerability/52a71bf1-b8bc-479e-b741-eb8fb9685014
Get alerted when CVE-2022-0189 or the next vulnerability affects your stack