What’s Vulnerable › Vulnerabilities
CVE-2022-0193: Complianz - GDPR/CCPA Cookie Consent < 6.0.0 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-14 · updated 2026-06-17
- Weakness: CWE-79
Description
The Complianz WordPress plugin before 6.0.0 does not escape the s parameter before outputting it back in an attribute in an admin page, leading to a Reflected Cross-Site Scripting
Affected products
- Complianz – GDPR/CCPA Cookie Consent: before 6.0.0 — fixed in 6.0.0
How to fix
Upgrade to a fixed version: Complianz – GDPR/CCPA Cookie Consent 6.0.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2654225
- https://wpscan.com/vulnerability/30d1d328-9f19-4c4c-b90a-04937d617864
- https://plugins.trac.wordpress.org/changeset/2654225
- https://wpscan.com/vulnerability/30d1d328-9f19-4c4c-b90a-04937d617864
Get alerted when CVE-2022-0193 or the next vulnerability affects your stack