What’s Vulnerable › Vulnerabilities
CVE-2022-0194
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-28 · updated 2026-06-17
- Weakness: CWE-121
Description
This vulnerability allows remote attackers to execute arbitrary code on affected installations of Netatalk. Authentication is not required to exploit this vulnerability. The specific flaw exists within the ad_addcomment function. The issue results from the lack of proper validation of the length of user-supplied data prior to copying it to a fixed-length stack-based buffer. An attacker can leverage this vulnerability to execute code in the context of root. Was ZDI-CAN-15876.
Affected products
- Debian Linux: 10.0, 11.0
- Netatalk: before 3.1.13 — fixed in 3.1.13
How to fix
Upgrade to a fixed version: Netatalk 3.1.13. Check the vendor advisory for mitigations.
References
- https://lists.debian.org/debian-lts-announce/2023/05/msg00018.html
- https://netatalk.sourceforge.io/3.1/ReleaseNotes3.1.13.html
- https://security.gentoo.org/glsa/202311-02
- https://www.debian.org/security/2023/dsa-5503
- https://www.zerodayinitiative.com/advisories/ZDI-22-530/
- https://lists.debian.org/debian-lts-announce/2023/05/msg00018.html
- https://netatalk.sourceforge.io/3.1/ReleaseNotes3.1.13.html
- https://security.gentoo.org/glsa/202311-02
- https://www.debian.org/security/2023/dsa-5503
- https://www.kb.cert.org/vuls/id/709991
- https://www.zerodayinitiative.com/advisories/ZDI-22-530/
Get alerted when CVE-2022-0194 or the next vulnerability affects your stack