What’s Vulnerable › Vulnerabilities
CVE-2022-0204
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-10 · updated 2026-06-17
- Weakness: CWE-119
Description
A heap overflow vulnerability was found in bluez in versions prior to 5.63. An attacker with local network access could pass specially crafted files causing an application to halt or crash, leading to a denial of service.
Affected products
- BlueZ: before 5.63 — fixed in 5.63
- Debian Linux: 10.0
- Fedoraproject Fedora: 35
How to fix
Upgrade to a fixed version: BlueZ 5.63. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=2039807
- https://github.com/bluez/bluez/commit/591c546c536b42bef696d027f64aa22434f8c3f0
- https://github.com/bluez/bluez/security/advisories/GHSA-479m-xcq5-9g2q
- https://lists.debian.org/debian-lts-announce/2022/10/msg00026.html
- https://security.gentoo.org/glsa/202209-16
- https://bugzilla.redhat.com/show_bug.cgi?id=2039807
- https://github.com/bluez/bluez/commit/591c546c536b42bef696d027f64aa22434f8c3f0
- https://github.com/bluez/bluez/security/advisories/GHSA-479m-xcq5-9g2q
- https://lists.debian.org/debian-lts-announce/2022/10/msg00026.html
- https://lists.debian.org/debian-lts-announce/2024/09/msg00022.html
- https://security.gentoo.org/glsa/202209-16
Get alerted when CVE-2022-0204 or the next vulnerability affects your stack