What’s Vulnerable › Vulnerabilities
CVE-2022-0213: Heap-based Buffer Overflow in vim/vim
- Severity: medium (CVSS 6.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-14 · updated 2026-10-08
- Weakness: CWE-122
Description
vim is vulnerable to Heap-based Buffer Overflow
Affected products
- Debian Linux: 9.0, 10.0
- vim/vim: before 8.2 — fixed in 8.2
How to fix
Upgrade to a fixed version: vim/vim 8.2. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2022/01/15/1
- https://github.com/vim/vim/commit/de05bb25733c3319e18dca44e9b59c6ee389eb26
- https://huntr.dev/bounties/f3afe1a5-e6f8-4579-b68a-6e5c7e39afed
- https://lists.debian.org/debian-lts-announce/2022/03/msg00018.html
- https://lists.debian.org/debian-lts-announce/2022/11/msg00009.html
- https://security.gentoo.org/glsa/202208-32
- http://www.openwall.com/lists/oss-security/2022/01/15/1
- https://github.com/vim/vim/commit/de05bb25733c3319e18dca44e9b59c6ee389eb26
- https://huntr.dev/bounties/f3afe1a5-e6f8-4579-b68a-6e5c7e39afed
- https://lists.debian.org/debian-lts-announce/2022/03/msg00018.html
- https://lists.debian.org/debian-lts-announce/2022/11/msg00009.html
- https://security.gentoo.org/glsa/202208-32
Get alerted when CVE-2022-0213 or the next vulnerability affects your stack