What’s Vulnerable › Vulnerabilities
CVE-2022-0217
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-08-26 · updated 2026-06-17
- Weakness: CWE-776
Description
It was discovered that an internal Prosody library to load XML based on libexpat does not properly restrict the XML features allowed in parsed XML data. Given suitable attacker input, this results in expansion of recursive entity references from DTDs (CWE-776). In addition, depending on the libexpat version used, it may also allow injections using XML External Entity References (CWE-611).
Affected products
- Prosody: before 0.11.12 — fixed in 0.11.12
How to fix
Upgrade to a fixed version: Prosody 0.11.12. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=2040639
- https://prosody.im/security/advisory_20220113/
- https://prosody.im/security/advisory_20220113/1.patch
- https://bugzilla.redhat.com/show_bug.cgi?id=2040639
- https://prosody.im/security/advisory_20220113/
- https://prosody.im/security/advisory_20220113/1.patch
Get alerted when CVE-2022-0217 or the next vulnerability affects your stack