What’s Vulnerable › Vulnerabilities
CVE-2022-0229: miniOrange's Google Authenticator < 5.5 - Unauthenticated Arbitrary Options Deletion
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-21 · updated 2026-06-17
- Weakness: CWE-352
Description
The miniOrange's Google Authenticator WordPress plugin before 5.5 does not have proper authorisation and CSRF checks when handling the reconfigureMethod, and does not validate the parameters passed to it properly. As a result, unauthenticated users could delete arbitrary options from the blog, making it unusable.
Affected products
- Google Authenticator: before 5.5 — fixed in 5.5
How to fix
Upgrade to a fixed version: Google Authenticator 5.5. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/d70c5335-4c01-448d-85fc-f8e75b104351
- https://wpscan.com/vulnerability/d70c5335-4c01-448d-85fc-f8e75b104351
Get alerted when CVE-2022-0229 or the next vulnerability affects your stack