What’s Vulnerable › Vulnerabilities
CVE-2022-0234: WOOCS < 1.3.7.5 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-21 · updated 2026-06-17
- Weakness: CWE-79
Description
The WOOCS WordPress plugin before 1.3.7.5 does not sanitise and escape the woocs_in_order_currency parameter of the woocs_get_products_price_html AJAX action (available to both unauthenticated and authenticated users) before outputting it back in the response, leading to a Reflected Cross-Site Scripting
Affected products
- PluginUS Woocs: before 1.3.7.5 — fixed in 1.3.7.5
How to fix
Upgrade to a fixed version: PluginUS Woocs 1.3.7.5. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2659191
- https://wpscan.com/vulnerability/fd568a1f-bd51-41bb-960d-f8573b84527b
- https://plugins.trac.wordpress.org/changeset/2659191
- https://wpscan.com/vulnerability/fd568a1f-bd51-41bb-960d-f8573b84527b
Get alerted when CVE-2022-0234 or the next vulnerability affects your stack