What’s Vulnerable › Vulnerabilities
CVE-2022-0239: Improper Restriction of XML External Entity Reference in stanfordnlp/corenlp
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-17 · updated 2026-06-17
- Weakness: CWE-611
Description
corenlp is vulnerable to Improper Restriction of XML External Entity Reference
Affected products
- stanfordnlp/corenlp: before 4.4.0 — fixed in 4.4.0
How to fix
Upgrade to a fixed version: stanfordnlp/corenlp 4.4.0. Check the vendor advisory for mitigations.
References
- https://github.com/stanfordnlp/corenlp/commit/1940ffb938dc4f3f5bc5f2a2fd8b35aabbbae3dd
- https://huntr.dev/bounties/a717aec2-5646-4a5f-ade0-dadc25736ae3
- https://github.com/stanfordnlp/corenlp/commit/1940ffb938dc4f3f5bc5f2a2fd8b35aabbbae3dd
- https://huntr.dev/bounties/a717aec2-5646-4a5f-ade0-dadc25736ae3
Get alerted when CVE-2022-0239 or the next vulnerability affects your stack