What’s Vulnerable › Vulnerabilities
CVE-2022-0251: Cross-site Scripting (XSS) - Stored in pimcore/pimcore
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-26 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Stored in GitHub repository pimcore/pimcore prior to 10.2.10.
Affected products
- pimcore/pimcore: before 10.2.0 — fixed in 10.2.0
How to fix
Upgrade to a fixed version: pimcore/pimcore 10.2.0. Check the vendor advisory for mitigations.
References
- https://github.com/pimcore/pimcore/commit/3ae96b9d41c117aafa45873ad10077d4b873a3cb
- https://huntr.dev/bounties/eb4b08f9-cf8b-4335-b3b8-ed44e5fa80a5
- https://github.com/pimcore/pimcore/commit/3ae96b9d41c117aafa45873ad10077d4b873a3cb
- https://huntr.dev/bounties/eb4b08f9-cf8b-4335-b3b8-ed44e5fa80a5
Get alerted when CVE-2022-0251 or the next vulnerability affects your stack