What’s Vulnerable › Vulnerabilities
CVE-2022-0255: Database Backup for WordPress < 2.5.1 - Admin+ SQL Injection
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-21 · updated 2026-06-17
- Weakness: CWE-89
Description
The Database Backup for WordPress plugin before 2.5.1 does not properly sanitise and escape the fragment parameter before using it in a SQL statement in the admin dashboard, leading to a SQL injection issue
Affected products
- Database Backup for WordPress: before 2.5.1 — fixed in 2.5.1
How to fix
Upgrade to a fixed version: Database Backup for WordPress 2.5.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/684bb06d-864f-4cba-ab0d-f83974d026fa
- https://wpscan.com/vulnerability/684bb06d-864f-4cba-ab0d-f83974d026fa
Get alerted when CVE-2022-0255 or the next vulnerability affects your stack