What’s Vulnerable › Vulnerabilities
CVE-2022-0256: Cross-site Scripting (XSS) - Stored in pimcore/pimcore
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-17 · updated 2026-06-17
- Weakness: CWE-79
Description
pimcore is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
Affected products
- pimcore/pimcore: before 10.2.8 — fixed in 10.2.8
How to fix
Upgrade to a fixed version: pimcore/pimcore 10.2.8. Check the vendor advisory for mitigations.
References
- https://github.com/pimcore/pimcore/commit/dff1cb0c466abcd55f1268934de3ed937b7436a7
- https://huntr.dev/bounties/8d88e48a-7124-4aaf-9f1d-6cfe4f9a79c1
- https://github.com/pimcore/pimcore/commit/dff1cb0c466abcd55f1268934de3ed937b7436a7
- https://huntr.dev/bounties/8d88e48a-7124-4aaf-9f1d-6cfe4f9a79c1
Get alerted when CVE-2022-0256 or the next vulnerability affects your stack