What’s Vulnerable › Vulnerabilities
CVE-2022-0257: Cross-site Scripting (XSS) - Stored in pimcore/pimcore
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-17 · updated 2026-06-17
- Weakness: CWE-79
Description
pimcore is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
Affected products
- pimcore/pimcore: before 10.2.8 — fixed in 10.2.8
How to fix
Upgrade to a fixed version: pimcore/pimcore 10.2.8. Check the vendor advisory for mitigations.
References
- https://github.com/pimcore/pimcore/commit/dfaf78b26fb77990267c0cc05b9fcb9f8de7b66d
- https://huntr.dev/bounties/bad2073c-bbd5-4425-b3e9-c336b73ddda6
- https://github.com/pimcore/pimcore/commit/dfaf78b26fb77990267c0cc05b9fcb9f8de7b66d
- https://huntr.dev/bounties/bad2073c-bbd5-4425-b3e9-c336b73ddda6
Get alerted when CVE-2022-0257 or the next vulnerability affects your stack