What’s Vulnerable › Vulnerabilities
CVE-2022-0258: SQL Injection in pimcore/pimcore
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-17 · updated 2026-06-17
- Weakness: CWE-89
Description
pimcore is vulnerable to Improper Neutralization of Special Elements used in an SQL Command
Affected products
- pimcore/pimcore: before 10.2.8 — fixed in 10.2.8
How to fix
Upgrade to a fixed version: pimcore/pimcore 10.2.8. Check the vendor advisory for mitigations.
References
- https://github.com/pimcore/pimcore/commit/66281c12479dc01a06258d8533eaddfb1770d5bd
- https://huntr.dev/bounties/0df891e4-6412-4d9a-a9b7-d9df50311802
- https://github.com/pimcore/pimcore/commit/66281c12479dc01a06258d8533eaddfb1770d5bd
- https://huntr.dev/bounties/0df891e4-6412-4d9a-a9b7-d9df50311802
Get alerted when CVE-2022-0258 or the next vulnerability affects your stack