What’s Vulnerable › Vulnerabilities
CVE-2022-0261: Heap-based Buffer Overflow in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-18 · updated 2026-06-17
- Weakness: CWE-122
Description
Heap-based Buffer Overflow in GitHub repository vim/vim prior to 8.2.
Affected products
- macOS: 10.12.6
- Apple macOS: before 13.0 — fixed in 13.0
- Debian Linux: 9.0, 10.0
- vim/vim: before 8.2.4120 — fixed in 8.2.4120
How to fix
Upgrade to a fixed version: Apple macOS 13.0; vim/vim 8.2.4120. Check the vendor advisory for mitigations.
References
- http://seclists.org/fulldisclosure/2022/Oct/28
- http://seclists.org/fulldisclosure/2022/Oct/41
- http://seclists.org/fulldisclosure/2022/Oct/43
- https://github.com/vim/vim/commit/9f8c304c8a390ade133bac29963dc8e56ab14cbc
- https://huntr.dev/bounties/fa795954-8775-4f23-98c6-d4d4d3fe8a82
- https://lists.debian.org/debian-lts-announce/2022/05/msg00022.html
- https://lists.debian.org/debian-lts-announce/2022/11/msg00009.html
- https://security.gentoo.org/glsa/202208-32
- https://support.apple.com/kb/HT213444
- https://support.apple.com/kb/HT213488
- http://seclists.org/fulldisclosure/2022/Oct/28
- http://seclists.org/fulldisclosure/2022/Oct/41
Get alerted when CVE-2022-0261 or the next vulnerability affects your stack