What’s Vulnerable › Vulnerabilities
CVE-2022-0285: Cross-site Scripting (XSS) - Stored in pimcore/pimcore
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-20 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Stored in Packagist pimcore/pimcore prior to 10.2.9.
Affected products
- pimcore/pimcore: before 10.2.9 — fixed in 10.2.9
How to fix
Upgrade to a fixed version: pimcore/pimcore 10.2.9. Check the vendor advisory for mitigations.
References
- https://github.com/pimcore/pimcore/commit/b432225952e2a5ab0268f401b85a14480369b835
- https://huntr.dev/bounties/321918b2-aa01-410e-9f7c-dca5f286bc9c
- https://github.com/pimcore/pimcore/commit/b432225952e2a5ab0268f401b85a14480369b835
- https://huntr.dev/bounties/321918b2-aa01-410e-9f7c-dca5f286bc9c
Get alerted when CVE-2022-0285 or the next vulnerability affects your stack