What’s Vulnerable › Vulnerabilities
CVE-2022-0314: Nimble Page Builder < 3.2.2 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-04-11 · updated 2026-06-17
- Weakness: CWE-79
Description
The Nimble Page Builder WordPress plugin before 3.2.2 does not sanitise and escape the preview-level-guid parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting
Affected products
- Nimble Page Builder: before 3.2.2 — fixed in 3.2.2
How to fix
Upgrade to a fixed version: Nimble Page Builder 3.2.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/17585f16-c62c-422d-ad9c-9138b6da97b7
- https://wpscan.com/vulnerability/17585f16-c62c-422d-ad9c-9138b6da97b7
Get alerted when CVE-2022-0314 or the next vulnerability affects your stack