What’s Vulnerable › Vulnerabilities
CVE-2022-0317: Improper Input Validation in AKPublic.Verify in go-attestation
- Severity: low (CVSS 3.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-02-04 · updated 2026-06-17
- Weakness: CWE-20
Description
An improper input validation vulnerability in go-attestation before 0.3.3 allows local users to provide a maliciously-formed Quote over no/some PCRs, causing AKPublic.Verify to succeed despite the inconsistency. Subsequent use of the same set of PCR values in Eventlog.Verify lacks the authentication performed by quote verification, meaning a local attacker could couple this vulnerability with a maliciously-crafted TCG log in Eventlog.Verify to spoof events in the TCG log, hence defeating remotely-attested measured-boot. We recommend upgrading to Version 0.4.0 or above.
Affected products
- Google go-attestation: before 0.3.3 — fixed in 0.3.3
How to fix
Upgrade to a fixed version: Google go-attestation 0.3.3. Check the vendor advisory for mitigations.
References
- https://github.com/google/go-attestation/security/advisories/GHSA-99cg-575x-774p
- https://github.com/google/go-attestation/security/advisories/GHSA-99cg-575x-774p
Get alerted when CVE-2022-0317 or the next vulnerability affects your stack