What’s Vulnerable › Vulnerabilities
CVE-2022-0318: Heap-based Buffer Overflow in vim/vim
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-21 · updated 2026-06-17
- Weakness: CWE-122
Description
Heap-based Buffer Overflow in vim/vim prior to 8.2.
Affected products
- Apple macOS: before 13.0 — fixed in 13.0
- Debian Linux: 10.0
- vim/vim: before 8.2.4151 — fixed in 8.2.4151
How to fix
Upgrade to a fixed version: Apple macOS 13.0; vim/vim 8.2.4151. Check the vendor advisory for mitigations.
References
- http://seclists.org/fulldisclosure/2022/Oct/28
- http://seclists.org/fulldisclosure/2022/Oct/41
- http://seclists.org/fulldisclosure/2022/Oct/43
- https://github.com/vim/vim/commit/57df9e8a9f9ae1aafdde9b86b10ad907627a87dc
- https://huntr.dev/bounties/0d10ba02-b138-4e68-a284-67f781a62d08
- https://lists.debian.org/debian-lts-announce/2022/11/msg00032.html
- https://security.gentoo.org/glsa/202208-32
- https://support.apple.com/kb/HT213444
- https://support.apple.com/kb/HT213488
- http://seclists.org/fulldisclosure/2022/Oct/28
- http://seclists.org/fulldisclosure/2022/Oct/41
- http://seclists.org/fulldisclosure/2022/Oct/43
Get alerted when CVE-2022-0318 or the next vulnerability affects your stack