What’s Vulnerable › Vulnerabilities
CVE-2022-0321: WP Voting Contest < 3.0 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-14 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP Voting Contest WordPress plugin before 3.0 does not sanitise and escape the post_id parameter before outputting it back in the response via the wpvc_social_share_icons AJAX action (available to both unauthenticated and authenticated users), leading to a Reflected Cross-Site Scripting issue
Affected products
- WP Voting Contest: before 3.0 — fixed in 3.0
How to fix
Upgrade to a fixed version: WP Voting Contest 3.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/286b81a0-6f6d-4024-9bbc-6cb373990a7a
- https://wpscan.com/vulnerability/286b81a0-6f6d-4024-9bbc-6cb373990a7a
Get alerted when CVE-2022-0321 or the next vulnerability affects your stack