What’s Vulnerable › Vulnerabilities
CVE-2022-0323: Improper Neutralization of Special Elements Used in a Template Engine in bobthecow/mustache.php
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-21 · updated 2026-06-17
- Weakness: CWE-1336
Description
Improper Neutralization of Special Elements Used in a Template Engine in Packagist mustache/mustache prior to 2.14.1.
Affected products
- bobthecow/mustache.php: from 2.0.0 before 2.14.1 — fixed in 2.14.1
How to fix
Upgrade to a fixed version: bobthecow/mustache.php 2.14.1. Check the vendor advisory for mitigations.
References
- https://github.com/bobthecow/mustache.php/commit/579ffa5c96e1d292c060b3dd62811ff01ad8c24e
- https://huntr.dev/bounties/a5f5a988-aa52-4443-839d-299a63f44fb7
- https://github.com/bobthecow/mustache.php/commit/579ffa5c96e1d292c060b3dd62811ff01ad8c24e
- https://huntr.dev/bounties/a5f5a988-aa52-4443-839d-299a63f44fb7
Get alerted when CVE-2022-0323 or the next vulnerability affects your stack