What’s Vulnerable › Vulnerabilities

CVE-2022-0333

Description

A flaw was found in Moodle in versions 3.11 to 3.11.4, 3.10 to 3.10.8, 3.9 to 3.9.11 and earlier unsupported versions. The calendar:manageentries capability allowed managers to access or modify any calendar event, but should have been restricted from accessing user level events.

Affected products

How to fix

Upgrade to a fixed version: Moodle 3.10.9, 3.11.5, 3.9.12. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-0333 or the next vulnerability affects your stack