What’s Vulnerable › Vulnerabilities
CVE-2022-0334
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-01-25 · updated 2026-06-17
- Weakness: CWE-863
Description
A flaw was found in Moodle in versions 3.11 to 3.11.4, 3.10 to 3.10.8, 3.9 to 3.9.11 and earlier unsupported versions. Insufficient capability checks could lead to users accessing their grade report for courses where they did not have the required gradereport/user:view capability.
Affected products
- Moodle: through 3.8.9; from 3.9.0 through 3.9.11; from 3.10.0 before 3.10.9; from 3.11.0 before 3.11.5 — fixed in 3.10.9, 3.11.5
How to fix
Upgrade to a fixed version: Moodle 3.10.9, 3.11.5. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=2043664
- https://moodle.org/mod/forum/discuss.php?d=431102
- https://bugzilla.redhat.com/show_bug.cgi?id=2043664
- https://moodle.org/mod/forum/discuss.php?d=431102
Get alerted when CVE-2022-0334 or the next vulnerability affects your stack