What’s Vulnerable › Vulnerabilities

CVE-2022-0335

Description

A flaw was found in Moodle in versions 3.11 to 3.11.4, 3.10 to 3.10.8, 3.9 to 3.9.11 and earlier unsupported versions. The "delete badge alignment" functionality did not include the necessary token check to prevent a CSRF risk.

Affected products

How to fix

Upgrade to a fixed version: Moodle 3.10.9, 3.11.5, 3.9.12. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-0335 or the next vulnerability affects your stack