What’s Vulnerable › Vulnerabilities
CVE-2022-0336
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-29 · updated 2026-06-17
- Weakness: CWE-276
Description
The Samba AD DC includes checks when adding service principals names (SPNs) to an account to ensure that SPNs do not alias with those already in the database. Some of these checks are able to be bypassed if an account modification re-adds an SPN that was previously present on that account, such as one added when a computer is joined to a domain. An attacker who has the ability to write to an account can exploit this to perform a denial-of-service attack by adding an SPN that matches an existing service. Additionally, an attacker who can intercept traffic can impersonate existing services, resulting in a loss of confidentiality and integrity.
Affected products
- Fedoraproject Fedora: 34, 35
- Samba: from 4.0.0 before 4.13.17; from 4.14.0 before 4.14.12; from 4.15.0 before 4.15.4 — fixed in 4.13.17, 4.14.12, 4.15.4
How to fix
Upgrade to a fixed version: Samba 4.13.17, 4.14.12, 4.15.4. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/security/cve/CVE-2022-0336
- https://bugzilla.redhat.com/show_bug.cgi?id=2046134
- https://bugzilla.samba.org/show_bug.cgi?id=14950
- https://github.com/samba-team/samba/commit/1a5dc817c0c9379bbaab14c676681b42b0039a3c
- https://github.com/samba-team/samba/commit/c58ede44f382bd0125f761f0479c8d48156be400
- https://security.gentoo.org/glsa/202309-06
- https://www.samba.org/samba/security/CVE-2022-0336.html
- https://access.redhat.com/security/cve/CVE-2022-0336
- https://bugzilla.redhat.com/show_bug.cgi?id=2046134
- https://bugzilla.samba.org/show_bug.cgi?id=14950
- https://github.com/samba-team/samba/commit/1a5dc817c0c9379bbaab14c676681b42b0039a3c
- https://github.com/samba-team/samba/commit/c58ede44f382bd0125f761f0479c8d48156be400
Get alerted when CVE-2022-0336 or the next vulnerability affects your stack